Skip to content
Advertisement
2011/02/01 / vpourchet

OCS Inventory : Forcer une remontée d’inventaire instantanée

Pour forcer une remontée d’inventaire instantanée depuis un poste sur lequel l’agent est installé, deux possibilités.

La première

Cliquer sur Démarrer puis exécuter puis entrer services.msc

Rechercher le service OCSInventoryAgent faire un clic droit dessus puis l’arrêter.

Se rendre dans le répertoire d’installation de l’agent, par défaut :

Rechercher le fichier ‘service.ini‘.

L’ouvrir avec notepad ou tout autre editeur de texte.

Rechercher la variable TTO_WAIT

Noter la valeur, puis la remplacer par zéro.

Redémarrer le service OCSInventory dans la console de gestion des services.

Vérifier la remontée d’inventaire.

Puis couper le service, et remettre la variable TTO_WAIT à sa valeur d’origine.

Ne pas oublier de redémarrer le service après l’opération.

La seconde

Dans une invite de commande, entrer manuellement la commande d’exécution de l’agent OCS avec les variables adéquates. Ex :

C:\> <chemin vers le repertoire d’installation de l’agent OCS>\OCSInventory.exe  /TAG :<votre tag> /SERVER : <adresse ip du serveur ocs> /PNUM :<port d’écoute> /NP /FORCE

L’option /FORCE devrait forcer une remontée d’inventaire instantanée.

4 Comments

Leave a Comment
  1. Fara / May 17 2012 17:32

    bonjour,

    J'ai installé ocsinventory 2.0.5 sur un server2008 qui est sur une vmware workstation. L'installation s'est bien effectuée ainsi que la configuration. J'ai effectué un déploiement via GPO, le déploiement s'effectue très bien mais j'ai aucune remonté dans ocs même en faisant les manipulation que vous avez donné ci-dessus.

    Pouvez vous m'aider!!!

    • vpourchet / May 25 2012 01:40

      Bonsoir,

      Les postes clients arrivent a pinguer le serveur OCS ?
      Quel est le contenu du log ?
      Cordialement,

      V

      • Fara / May 25 2012 17:23

        Les postes clients pingue bien le serveur OCS.

        Merci pour ton aide. Je pense avoir trouvé la solution.

        En regardant le fichier log et ocsinventory.ini d'un poste, je me suis rendu compte que l'adresse serveur n'était pas la bonne j'avais SERVER=http://ocsinventory-ng/ocsinventory.

        J'ai effectué un changement manuelle sur un poste en mettant l'adresse de mon serveur OCS

        SERVER =http://192.168.X.X:8080/ocsinventory et la j'ai eu une remonté instantané de la machine.

        Donc je vais refaire un déploiement en ajoutant cette commande dans les paramètres pour que chaque machine est le bon chemin du serveur ocs.

        Voilà

        • vpourchet / May 26 2012 12:45

          Super,

          Ravi que celà fonctionne enfin.

          Bon week-end.

          Cordialement,

          V

Leave a Reply

Your email address will not be published.